Dai geni ai pathways – Functional Genomics with R (FunGR)

This content is protected, please login and enroll course to view this content!

5 commenti

  • Ho installato la versione di R 3.5.1
    Quando provo ad installare il package ggplot mi risponde con un warning dicendo che questo package is not available per quella versione.
    Perché già integrato o troppo obsoleto? Esiste qualcosa di similare?

    Rispondi
  • sto provando a installare CRAN e mi dice package ‘CRAN’ is not available (for R version 3.5.1). Uso un MAC

    Rispondi
    • Infobio Infobio ha detto:

      Attenzione che il “CRAN” non è un package, e non si può installare!! Il CRAN è il repository (il database) che continene i pacchetti. I pacchetti da installare sono quelli indicati sopra in questa pagina: “dplyr”, “ggplot2” e “tidyr”, e altri che però vedremo durante il corso.
      La riga di comando per il primo sarà quindi:
      install.packages(“dplyr”)
      oppure
      install.packages(“dplyr”, repos = “https://cran.rstudio.com”)

      Nota per i possessori di MAC
      Se sul vostro MAC non è installato il componente Xcode che serve, tra le altre cose, per la compilazione dei pacchetti, potreste avere messaggi di errore. Se questo è il caso (leggete cosa dice il messaggio di errore), potreste provare a fare quanto segue:
      – aprire il terminale e provare a digitare il comando “make” oppure il comando “gcc” (sono comandi che richiedono X-code)
      – se questo è il problema dovrebbe comparire una finestra pop-up che chiede di installare il tool.
      – se così accade cliccare su “Install” (non su “Get Xcode”) e seguire le istruzioni.
      – riprovare a installare i pacchetti

      Rispondi

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *